1

I recently updated Craft Commerce to version 4.6.0, but now whenever I run any Craft commands or navigate to site.com/admin, I encounter the following error:

You need to be on at least Craft Commerce 3.4.11 before you can update to Craft Commerce 4.6.0.

However, I have confirmed that I'm running Craft Commerce 4.6.0 using the command:

composer info --tree | grep "commerce"

which outputs:

craftcms/commerce 4.6.0 Craft Commerce

Why does this error occur even though I have the latest version installed, and how can I resolve it?

PS. this works fine in localhost, but not in staging. weird indeed. I also have an warning in the output but not sure that causes the main issue

Warning: PHP Startup: Unable to load dynamic library 'php_xmlrpc.so' (tried: /usr/lib64/php8.2/php-ext/php_xmlrpc.so (/usr/lib64/php8.2/php-ext/php_xmlrpc.so: cannot open shared object file: No such file or directory), /usr/lib64/php8.2/php-ext/php_xmlrpc.so.so (/usr/lib64/php8.2/php-ext/php_xmlrpc.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

1 Answer 1

1

With regards to Composer, you are indeed running Commerce 4.6.0.

However, Craft is trying to keep up, and can't update directly to 4.6.0. The message you are seeing is telling you that Craft wants you to install Commerce 3.4.11 (via Composer), and run all of your updates to that version.

Once you've done that, you should then be able to circle back and update all the way to 4.6.0, as a completely separate step.

1
  • The thing is that I could not roll back to Craft Commerce v3.4.11 since I upgraded the CraftCMS to v4 and is not compatible with the older version of Craft Commerce. Commented May 13 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.