1

In Craft CMS 4.8.10 I have updated my plugins via command-line and in the control panel and they both come back with the updates successful. But in the control panel the updates continue to appear again and if I run the update in command line the same thing happens with those updates listed again as needed to be installed.

Strange this is it is a set of updates for 4 plugins Ckeditor, Seomatic, Supertable and Imager x. Updates for some other plugins and craft itself have come in since this issue arose and when I run the update they complete and don't show again but those other plugins stuck. Thanks for any help

2 Answers 2

2

You likely have pinned versions set for those four plugins. Check your composer.json file; do those plugins have a ^ before the versions or not? If not, they're pinned to those versions and will not update to the next non-major version.

Why?

Because updating Craft and plugins via the Craft control panel results in Craft pinning the versions of whatever it installs or updates. Through the command line that does not happen.

Since you describe doing updates both through the command line and the Craft control panel, you're getting a mix of both, and that can have (un)predictable results. You should choose one method (command line or control panel) and stick with it and always do it that way.

To fix your issue: add ^ to the versions of the packages in your composer.json where they aren't and then update again from the command line. Everything should update as expected.

1
  • Thanks for the answer and that all makes sense, but the solution doesn't work for me . I have added the caret ^ to the plugins in composer. Json and ran the update in command line but the same thing happens with the updates completing but not updating. When in look at composer. json after the update the ^ I added has been stripped out and the version is set to the latest version of the plugin. I have also tried setting the plugin version back to be the same as the version that I have installed but again the ^ gets stripped out and version changed to the latest. Thaks for any help
    – bhackett
    Commented May 21 at 15:55
1

After reding through this https://nystudio107.com/blog/updating-craft-cms-without-headaches I nuked the vendor folder and reset everything using this command

rm -rf vendor/ && rm composer.lock && composer clear-cache && composer update

This sorted my issue and I am now fully up to date and will only do future updates via commandline

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.