0

A client's site is producing Internal Server Errors randomly in the Craft backend (3.7.53.1). The Dashboard produces an error. Saving certain entries produces an error (especially when enabling entires.

I have done the following:

  • Increased Memory Limits to 512M
  • Checked PHP Errors (nothing)
  • Checked web.log. It's very hard to make sense of this. There are no clear error messages here
  • Checked System Report (nothing obvious).
3
  • If the Internal Server Error was generated by Apache/nginx, then the underlying error should be in the web server's error lots. Did you check those?
    – Brad Bell
    Apr 12 at 18:24
  • Yah, and not much... Only errors Im seeing are: mod_fcgid: error reading data, FastCGI server closed connection; util_script.c(506): End of script output before headers: php73_wrapper.sh Apr 13 at 19:02
  • Sounds like you’re running Apache. This is on a production site? It feels like you're hitting some timeout somewhere in the stack. I'd hit up your hosting provider, show them the error, and see what they suggest. Chances are they've seen the error before and know a solution.
    – Brad Bell
    Apr 16 at 1:19

1 Answer 1

0

Thank you for all the comments and Tommy at Craft for assistance on this. After speaking with the host, we upgrades php from 7.3 to 8.2 and upgraded Craft to the final version of Craft 3. This has resolved the issue!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.