2

I followed the upgrade instructions. My current version is 4.8.1. When I run composer update, I get the following error: enter image description here

I added the following code to composer.json because of another issue:

  "minimum-stability": "dev",
  "prefer-stable": true,

How can I solve the error message to upgrade to 5.x?

2 Answers 2

2

You'll have to change your dependency on craftcms/generator in your composer.json file to this (it's likely in the require-dev section):

"craftcms/generator": "^2.0.0"

Alternatively, if you don't actually use Craft Generator, you can remove the dependency altogether.

1
  • Thank you. That worked exactly as it should and I was able to complete the upgrade to version 5.x-beta.
    – flip
    Commented Mar 12 at 13:31
0

For me, it looks like ... you have to uninstall the generator plugin at first?

1
  • I didn't want to delete it because it was delivered out-of-the box with Craft CMS. Requiring another version for the generator solved my issue.
    – flip
    Commented Mar 12 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.