1
Craft CMS 4.8.0
SEOmatic 4.0.42

I have configured the meta cascade according to plugin documentation - defined Global and Section SEO settings with default values - and I've also created an SEO Settings field and attached it to my entries.

Content SEO Settings: enter image description here

Entry SEO Settings: enter image description here

Output: enter image description here

I'm finding that whatever overrides I define on an entry are NOT overriding Content SEO values. In this example the & was replaced with and in the SEO Title Source override field.

No SEOmatic tags have been added to my document head template, so the tags being rendered are automatically generated by the SEOmatic plugin.

Things I've tried:

  1. Cleared all caches,
  2. Confirmed the document head template partial does not contain any Craft {% cache %} tags,
  3. Resaved sections,
  4. Resaved entries, and
  5. Turned on debug bar and checked SEOmatic tab.

The debug bar > SEOmatic tab shows no variables present for Entry SEO overrides, even though the override toggles are turned on and custom values are entered into the entry's SEO Settings field, which confirms what I'm noticing in rendered pages.

Plugin documentation seems to indicate the Entry SEO overrides should automatically be picked up and override Content SEO values, but that's not happening.

Am I missing a step somewhere, or do I need to insert an SEOmatic tag into the document head to force the overrides?

3
  • Can you provide a screenshot of the SEO Settings field on one of your entries where this is not working as you're expecting it to? Mar 4 at 21:36
  • Can you try re-saving your Content SEO settings? Also check to ensure you have things filled out in Global SEO as well? Worst case you can file an issue, and we can get on a video conf and have a look: github.com/nystudio107/craft-seomatic/issues Mar 6 at 3:19
  • Global SEO is fully populated. Tried resaving Content SEO Settings and clearing caches, and still seeing the same behavior - entry overrides not overriding Content SEO Settings. I'll submit an issue in GitHub. Mar 6 at 16:28

2 Answers 2

2

Turns out the issue was being caused by the fact that another SEO plugin was still installed.

Client was using the ether/seo plugin before, and I left it installed intentionally so the client could have some time to migrate values from that plugin's fields into SEOmatic entry overrides.

Now that the client has finished migrating values I've removed the the ether/seo plugin and its field type, and things appear to be working properly now with SEOmatic entry overrides actually overriding Content SEO values.

1

As a test, here's a blog entry title with it set up to use the {{ entry.title }} for the Content SEO settings for the Blog section:

enter image description here

Then I set up a SEO Settings field and override the Title like so:

enter image description here

...and then I reloaded the frontend, and it's displaying as expected with the new Custom Title text:

enter image description here

Can you provide similar screenshots for your setup, so we can see what's different, and why this isn't working as expected for you?

1
  • Issue description updated with screenshots Mar 5 at 1:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.