1

I just updated a site to Craft 4 and the debug toolbar no longer shows on the frontend, but does show in the CP. Have not had this issue with other sites that were updated.

Any ideas?

3 Answers 3

2

This can happen if the HTML on the site’s front end is malformed. e.g. you have an opening body tag, but you’re missing the closing.

View the source on the page and run it through an HTML validator to verify.

1

clearing caches / Forced browser reload is something that helps me out when it comes down to render changes..

1
  • Thanks, Stef - tried that but no luck. Even tried a browser on a different computer that I never use for dev, same issue.
    – Roi Agneta
    Nov 14, 2023 at 17:23
1

Maybe too obvious question, but.. did you check that checkmarks are set correctly for the debug tool in the account settings(My Account -> Preferences)?

Also, devMode is off/on on your website?

enter image description here

1
  • Thanks for the response - yes, all double checked.
    – Roi Agneta
    Nov 15, 2023 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.