1

First, apologies, I'm very much a Craft newbie. The contract we had with a vendor to manage our Craft install wasn't renewed so we're left trying to manage it internally the best we can.

We're running Craft Pro v3.6.9 as an Azure web app. We don't have a true dev environment, as such, but we have a staging deployment slot in the web app (alongside the prod one).

Anyway, we're needing to purchase and install a new plug-in for our production system (SAML Identity Provider). It seemed like, in theory, we should be able to select the plug-in from the plugin store in the Craft console then purchase and install it.

At first look, there was no option on the plugin details page to do that. We found in the docs that if admin changes are disabled, the plugin store would, effectively, be read-only. To change that, we needed to update the setting 'allowAdminChanges' (for the prod environment) to 'true' in config/general.php.

That change was made and the web app was restarted. I now see a 'Settings' option in the left menu that wasn't there before so it seems like the change took effect. However, we're still not seeing the option to buy/install when we open a plugin's details page.

Is there something else that needs to be done to enable that?

Thanks, Robin

1 Answer 1

1

Yes, if you are seeing a settings option then you should be able to install stuff, though I'd not recommend doing that straight into production without testing and without a full database backup first.

Below settings is the 'Plugin store' option, and each plugin should have an 'Add to cart' and 'Try' option for paid plugins, e.g:

enter image description here

If you don't see these buttons you should also check that allowUpdates is also not set to false in config/general.php

5
  • Seth, thanks for taking the time to respond. Completely understood about using Dev, backups, etc. The screen shot you included is what we'd expected to find, based on what we'd read. But, what we see is the above but without the "Add to cart" or "Try" options. So, just the pricing information.
    – RobinH
    Aug 24, 2023 at 13:56
  • OK, maybe you have allowUpdates set to false in config/general.php ? craftcms.com/docs/3.x/config/config-settings.html#allowupdates Aug 25, 2023 at 9:31
  • I'd highly recommend getting yourself set up with a local development environment, as that will allow you to experiment safely, test things and have a degree of confidence in the changes you deploy; without ruining your day by taking down production. DDEV is excellent and would be my first choice: ddev.readthedocs.io/en/latest/users/quickstart/#craft-cms Aug 25, 2023 at 9:34
  • 1
    That was it - allowUpdates was set to false. I didn't realize that was tied to allowAdminChanges in such a way. I will make the case for creating a DEV environment to test this first - thanks for the recommendation of DDEV. Thanks again for the assistance on this.
    – RobinH
    Aug 25, 2023 at 12:58
  • No problem! I've updated my original answer with the correct solution. It would be appreciated if you can mark it as the correct answer. TIA. Aug 25, 2023 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.