1

not sure what I did but my DEFAULT_SITE_URL in .env was set to http instead of https 0and when I tried to login to control panel on my desktop the page would load but when I submit the login form it is posting to http and the browser is blocking the submit. I updated the url to https and same thing.

I was able to login to the control panel on my cell phone using opera and updated the site url from http to https as well and I still get the same issue on my desktop. It seems that the control panel assets are still trying to be loaded over http instead of https so that browser is blocking them.

I have cleared all caches. I am on 3.8.7 if that matters.

Ideas of what else I can to have the login form post to https instead of http?

6
  • Can you try a different browser? I know Chrome can be particularly heavy-handed in caching SSL-related information (in spite of clearing the browser's cache).
    – Brad Bell
    May 9, 2023 at 22:07
  • I have tried Chrome, Edge, Opera and Firefox. The only I have got to work is Opera on my cell phone.
    – Trevor Orr
    May 9, 2023 at 22:28
  • I also just installed Brave and get the same result with it.
    – Trevor Orr
    May 9, 2023 at 23:53
  • Hrm... how are you using DEFAULT_SITE_URL in Craft? Pulling it in under Sites in the Control Panel? Are you additionally defining site URLs in config/general.php?
    – Brad Bell
    May 10, 2023 at 3:23
  • I am now able to login to the admin. In chrome I added my domain in the config setting for Sites that can always use cookies and checked the option for Including third-party cookies on this site. That seems to allow me to log into the admin
    – Trevor Orr
    May 10, 2023 at 14:35

1 Answer 1

2

In chrome I added my domain in the config setting for Sites that can always use cookies and checked the option for Including third-party cookies on this site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.