1

I installed this https://github.com/boboldehampsink/export plugin but getting error during exporting entities regarding to "count(): Parameter must be an array or an object that implements Countable", I tried to debug and applied some condition but not working, you can see in the screenshot.

enter image description here

1 Answer 1

3

That could be related to the version of PHP on your server being too new for the version of Craft you're using.

I'm sure you're aware, but Craft 2 is no longer supported; I'd recommend updating to 3 (ideally 4) as soon as possible. Craft 3 and 4 also support exporting from the control panel natively without plugins.

2
  • there are php 7.2. Could you please suggest which version should we use for making compatible for the this export plugin. Is it easy to move craft 2 to craft 3?
    – Nik Dev
    Commented May 2, 2023 at 14:46
  • 2
    @NikDev, You might give php v5.6 a try if v7.2 still gives you trouble. As far as upgrading, I would recommend going here: craftcms.com/docs/3.x/upgrade.html. The ease of updating will have to do a lot with the complexity of the site.
    – Jeff Irwin
    Commented May 2, 2023 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.