2

We recently updated one of our biggest projects to Craft 4. And today I tried to resave all the matrix block with resave/matrix-blocks but was greeted with the following behaviour:

enter image description here

Does anybody have a similar problem or know what might cause this? Using the CP works expected without any problems. And the logs don't show me anything to work with.

Leonardo

1
  • I cant't remeber how we solved this issue. sorry
    – Leonardo
    Feb 13 at 7:34

1 Answer 1

1

As mentioned in the official docs, the resave/matrix-blocks command needs the --field (i.e. a Matrix field handle) or --element-id (IDs of specific blocks to resave) arguments, on order for Craft to pull in the correct content tables.

This means that you won't be able to resave all Matrix blocks in a single command, but have to them field by field, i.e.

./craft resave/matrix-blocks --field matrixFieldHandle

...where matrixFieldHandle should be replaced with an actual Matrix field handle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.