1

I have already done some research and have not found anything related to my specific problem.

Quite some time ago I installed Imagick on my VPS and thus enabled the use of the Webp image format in the image transformations (Also selectable in the dropdown menu when setting up a transformation). The project I set it up for is still running on Craft 3 and the webp transforms still work fine.

enter image description here

Now I have multiple Craft 3/4 projects set up on the same server, and although "Webp Support" is enabled in CP > PHP Info, only jpg, png and gif can be selected as the format in the transforms.

enter image description here

For all Craft installations (whether v3 or v4) this info applies:

  • PHP version: 8.0.25
  • Image driver & version: Imagick 3.7.0 (ImageMagick 6.9.10-68)
  • WebP Support: Enabled
  • System requirements: All checked

Am I missing something obvious? I also don't remember setting up anything special in the installation where it works fine.

If any other info is needed, I'll be happy to provide it. :)

Edit: Looking at PHP Info in CP again, I noticed that "WEBP" is not listed in "ImageMagick supported formats". This applies to all installations, including the one where webp is shown as a format option in the transformations dropdown and it's just working fine.

enter image description here

1 Answer 1

1

So, by the looks of it I'm a little dumb and didn't find this article on how to work around that issue. If you have this issue using cPanel this will help you out.

Short version:

When using EA-PHP, (cPanel provided PHP) the ImageMagick PHP PECL extension uses the ImageMagick RPM package that is provided by the CentOS repository. This CentOS provided ImageMagick package is not compiled with webp support, so it is not possible to use the webp format with ImageMagick and EA-PHP in an officially supported way.

Full article: How to enable the webp image format for use with ImageMagick on cPanel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.