0

I can't export my database in the control panel. Craft 4.2.3, server is running multiple Craft instances and this is the only one getting this error. I'm not getting anything out of the logs, maybe someone else can?

Stack Trace

2022-10-20 06:53:08 [web.INFO] [yii\db\Connection::open] Opening DB connection: mysql:host=127.0.0.1;dbname=zidacahu_digitalpolitik2022;port=3306 {"memory":865784} 
2022-10-20 06:53:08 [web.INFO] [yii\web\Session::open] Session started {"memory":1297256} 
2022-10-20 06:53:08 [web.INFO] [nystudio107\twigfield\Twigfield::bootstrap] Twigfield module bootstrapped {"memory":1331640} 
2022-10-20 06:53:08 [web.INFO] [nystudio107\seomatic\Seomatic::init] SEOmatic plugin loaded {"memory":1877016} 
2022-10-20 06:53:08 [web.ERROR] [yii\base\Exception] yii\base\Exception: Could not create backup: Database not backed up because the backup command is false. in /home/zidacahu/public_html/2022_digitalpolitik/vendor/craftcms/cms/src/controllers/UtilitiesController.php:228
Stack trace:
#0 [internal function]: craft\controllers\UtilitiesController->actionDbBackupPerformAction()
#1 /home/zidacahu/public_html/2022_digitalpolitik/vendor/yiisoft/yii2/base/InlineAction.php(57): call_user_func_array(Array, Array)
#2 /home/zidacahu/public_html/2022_digitalpolitik/vendor/yiisoft/yii2/base/Controller.php(178): yii\base\InlineAction->runWithParams(Array)
#3 /home/zidacahu/public_html/2022_digitalpolitik/vendor/yiisoft/yii2/base/Module.php(552): yii\base\Controller->runAction('db-backup-perfo...', Array)
#4 /home/zidacahu/public_html/2022_digitalpolitik/vendor/craftcms/cms/src/web/Application.php(301): yii\base\Module->runAction('utilities/db-ba...', Array)
#5 /home/zidacahu/public_html/2022_digitalpolitik/vendor/craftcms/cms/src/web/Application.php(625): craft\web\Application->runAction('utilities/db-ba...', Array)
#6 /home/zidacahu/public_html/2022_digitalpolitik/vendor/craftcms/cms/src/web/Application.php(280): craft\web\Application->_processActionRequest(Object(craft\web\Request))
#7 /home/zidacahu/public_html/2022_digitalpolitik/vendor/yiisoft/yii2/base/Application.php(384): craft\web\Application->handleRequest(Object(craft\web\Request))
#8 /home/zidacahu/public_html/2022_digitalpolitik/web/index.php(12): yii\base\Application->run()
#9 {main} {"memory":2436880,"exception":"[object] (yii\\base\\Exception(code: 0): Could not create backup: Database not backed up because the backup command is false. at /home/zidacahu/public_html/2022_digitalpolitik/vendor/craftcms/cms/src/controllers/UtilitiesController.php:228)"}

1 Answer 1

1

Try to check you config/general.php if you found this, try to set to true or remove it.

'backupCommand' => false,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.