1

As mentioned in the title, I'm not able to upload any files in Craft4. I created a filesystem and a volume which is connected to the filesystem. In the assets-field settings I added the volume. I have no idea what I'm doing wrong. For any help I would be grateful. I'm using Craft v4.1.3

3
  • Is it local storage? Are you sure the volume has write permissions?
    – RomanAvr
    Jul 9, 2022 at 20:26
  • @mcoze Would you be able to elaborate more on your new settings? My base path is set to "@webroot/uploads" but I'm still getting the same error. Aug 15, 2022 at 10:54
  • I put a bit more of explanation in the anwer above, hope that helps
    – mcoze
    Aug 19, 2022 at 9:29

1 Answer 1

3

I must have looked at the screen for too long. The problem was that I didn't use relative path and url settings. https://craftcms.com/docs/3.x/sites.html#step-6-check-your-asset-volumes-settings

Here is a bit more of clarification @samroberts707 asked for: If your base path is set to @webroot/uploadsin Crafts Filesystem Settings then the Base-Url should be set to uploads, at least that is what I did.

1
  • 1
    Besides setting the base path URL, need to ensure owner is set to daemon:daemon Jan 3, 2023 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.