0

I have a craft v3 site using Wheelform plugin to power a custom 'job application' form.

The 'job application' form has a 'CV' upload file field.

The submissions from the form are sent as email user notifications that get delivered with an attached CV pdf (from the 'CV' upload file field) with 'save entries' turned off in WheelForm 'Job Application' form settings.

We have a custom 'file' directory that stores uploaded files in the Craft Assets page.

The issue:

We need to ensure that the uploaded 'CV' files are not stored in 'File' directory in Assets, and are only attached to the submitted user email notifications. (It's a GDPR things where the client cannot store personal data in the Craft backend, hence 'Save entries turned off in form settings).

Is it possible to disable 'Assets' from receiving an uploaded file?

I have attempted to deselect an upload directory from the 'Volume' settings in WheelForm by selecting '-- Select Volume --' on the 'Volume' drop-select menu, but that does not appear to work.

Any ideas how I can disable Asset uploads for the form?

Many thanks in advance.

Karl

1 Answer 1

0

When a Volume is not selected, Files should just be uploaded to the Craft temp folder. This is needed so the file can be attached to the email after submission. You can create a small cron job that deletes the temp folder daily to ensure nothing is being stored there. I think adding the option to "skip Volume saving" is a good feature, this way you don't have to disable Volumes for all the forms when 1 doesn't need them.

1
  • Hi @Xpertbot many thanks for this. When I select '-- Select Volume --' on the form settings form settings, I've since found it ** does ** actually attach the uploaded document to the sent email, so all works as expected. (I was using MailHog on my local setup of the site to check 'local' inbound email and MailHog made it look like attachments were not working!). I've now added a cron script to remove uploads from Craft temp directory, and this works a treat! Many thanks once again! Aug 1 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.