After installing a fresh version of Craft 4, the setup didn't allow me to specify the site language fr-FR as it did with the previous version. I had to accept the default en-US.

I thought that I would be able to fix that afterward in the control panel, but the only choices available are English variants.

I don't mind if the CP isn't fully translated yet, but it seems to me that I should be able to setup multiple languages. What did I miss ?


4 Answers 4


You might be missing the Intl PHP extension, which is required in Craft 4.

You can verify if that's the case by visiting the Utilities -> System Report section and look for the Intl status under Requirements:

enter image description here

  • The extension is indeed available.
    – fdelaneau
    Jun 13 at 7:58
  • Same issue. Craft 3.7.44 and Craft 4.0.4 (new install) running inside Nitro. The Intl extension is OK as well.
    – jjem
    Jun 17 at 12:51
  • Update: All languages are available on staging server but not locally within Nitro. Looks like a Nitro bug.
    – jjem
    Jun 17 at 13:15

If you are running inside Nitro, try updating your docker images with nitro update. It solved a similar issue for me.

  • I tried the nitro update, and checked that I could change the CP language for my user : It works. BUT, I am still unable to create a new site in French from the CP. The only options are local English variants.
    – fdelaneau
    Jun 13 at 8:13
  • I tried to create a brand new craft install after the nitro update and used the manual setup instead of the terminal to no avail, the only options are once more the English variants.
    – fdelaneau
    Jun 13 at 8:15

Found this solution that worked for me: https://github.com/craftcms/docker/issues/60

docker exec -it --user root YOUR_CONTAINER_NAME sh

then with

apk add icu-data-full

followed by a restart of the container gives me all languages back. Credit Mankeldor. Thanks


The problem was due to the PHP docker container used by Nitro.

Craft’s team fixed it and after updating Nitro everything is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.