3

I'm working on a site on shared hosting and I can't run composer install from CLI to install the vendor folder because I get

The Process class relies on proc_open, which is not available on your PHP installation

and proc_open can't be enabled because it's a security risk.

I can upload the vendor folder from my local and everything works fine but when I go to apply YAML changes, I get:

Your project config YAML files are expecting different versions to be installed Try running composer install from your terminal to resolve.

With the vendor folder already in place, if I run composer install I get everything is up to date. I've tried running composer dump-autoload and then composer install and get the same thing.

So how can I get around this so that I can apply the latest project config changes?

1
  • When I rebuild the project config, the schema version changes(fixed the issue), but also it has an impact on multiple files. For example, in the 'servd\AssetStorage\AssetsPlatform\Fs' type, the subfolder path value changes from 'staging/images' to 'local/images' in the 'project.yml' file. Is this potentially dangerous for the live site because the path now indicates the local file path, and the 'changedFieldIndicator' value of supertable plugin is set to null? ![subfolder Path is changed from staging to live](i.sstatic.net/QDsbW.png) [![change Commented Oct 30, 2023 at 7:01

1 Answer 1

7

That error occurs when there is a discrepancy between the schema versions listed in your incoming project config YAML, and what’s actually installed.

If you have the site installed locally, try rebuilding the project config (UtilitiesProject ConfigRebuild), and then upload the new config/project/ folder to production.

1
  • That did it, thanks Brandon. 👍
    – Tyssen
    Commented Apr 6, 2022 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.