2

I am trying to create the homepage of my company in several different languages. Here is what I did:

  1. Under Settings>Sites, I created a site for each language with a base URL
  2. Under Settings>Sections, I enabled the site for the sections which I want translated (for example home page section)
  3. After that, I can see each site on the dropdown menu when I go to Entries>Editor

My assumption was that when I select French site (for example) from the dropdown and translate the content within the editor, it would limit the changes only to the French site. However, it is making changes globally and my English site content is also getting translated. What am I doing wrong?

1 Answer 1

3

You need to change the translation method for every field you want to be translatable. By default, all fields are set to Not translatable, which means changing the field in one language will change it for all of them. For some fields this may be what you want, for others it won't be, you can decide this for every field.

To change the translation method, go to Settings -> Fields -> [Your field] and set the Translation Method to something other than Not translatable. The available options are documented here. Repeat this for every field you want to be translatable.

For asset fields, there isn't a translation method option. There is however an option under Advanced to Manage relations on a per-site basis. This allows you to select a different asset in this field for every site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.