0

I'm gettting the following error while trying to update within the control panel.

Fehler: curl error 7 while downloading https://composer.craftcms.com/packages.json: Failed to connect to composer.craftcms.com port 443: Connection refused Composer-Ausgabe: Loading composer repositories with package information

I'm suspecting some sort of it infrastructure problem but i'm not 100% sure and I'm wondering if anyone else had this problem aswell.

I've tried adding our proxy in the config/guzzle.php file but this didn't work for me.

<?php

return [
    'proxy' => 'http://myproxy.com:1234',
];

Does anyone else have an idea or can you confirm it's a infrastructure problem? If so, i might just need to reach out to our IT-Guy.

Any inputs are appreciated.

3
  • Can you successfully curl composer.craftcms.com/packages.json from a terminal on that same box? Or load it in a browser on the same box? If not, sounds like it's being blocked by a firewall or some such on the network.
    – Brad Bell
    Commented Jan 10, 2022 at 23:13
  • @BradBell Thank you for your answer. Isn't it possible to work around the firewall by defining the proxy? Is maybe my guzzle file not correct? I'll check it anyway with our IT :)
    – Marco
    Commented Jan 12, 2022 at 9:12
  • Depends on the version of Craft - older versions had some bugs in config/guzzle.php implementation. But even in a working setup, plugins (or anything that doesn't use Craft's native Guzzle client) don't have to respect that setting.
    – Brad Bell
    Commented Jan 13, 2022 at 4:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.