0

I'm running into some odd behavior with an entries field. There are multiple entries fields on the site and all work as expected but one. The behavior is as follows.

  • If there are multiple entries already associated, rearranging the entries (drag and drop) and then saving will clear all entries from the field.
  • Saving more than one entry to the field at a time (in one save event, not in total) will remove everything but the most recently clicked entry.
  • Saving entries individually, adding an entry, saving, adding another, saving, etc. is the only way currently to add multiple entries to the field.

Some further details:

  • The field has worked correctly for a long time until recently. The site was updated from Craft 3.1 to 3.7. I believe this is when it stopped working.
  • The production site runs on PHP 7.2.24. When I run my local on a similar version, I can recreate the error, but upping my local PHP to 7.4.1 removes the issue. Updating the PHP version of the production site is not an option at this time.
  • I've checked the craft logs as well as the php error logs and mysql logs. No errors appear, nor is an error thrown when saving, not even a flash message error.
2
  • As of Craft 3.6.0, PHP version 7.2.5 is required. github.com/craftcms/cms/blob/develop/… That might be the issue.
    – CraftQuest
    Dec 28, 2021 at 23:21
  • @CraftQuest I mentioned above, but the site currently exceeds 7.2.5. It's on php 7.2.24. Running my local on 7.2.33 also recreates the problem. So the issue does seem to be tied to a lower PHP version, but the site does exceed the minimum reqs from Craft. Jan 5, 2022 at 12:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.