0

Earlier updates for Craft always worked for me, but when I tried to install a plugin or update Craft this morning I got the following error:

Composer was unable to install the update

"Error: realpath(): open_basedir restriction in effect. File(/etc/pki/tls/certs/ca-bundle.crt) is not within the allowed path(s)"

Has anyone an idea what could cause this? We indeed have no access to this folder, but shouldn't composer be trying to change anything outside our user folder anyway? We tried to migrate to another server and disable open_basedir for our user account but that did not solve the issue.

I have the feeling that there is something wrong with how craft is accessing or using the certificates in our case, but don't know how to change the path where it is searching for them.

1
  • Are you able to add that path to your php.ini file's open_basedir setting?
    – Brad Bell
    Nov 28 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.