1

I am trying to upgrade to the Craft CMS from 3.5.8 to 3.7.21. I am getting the below error. Any help really helpful.

Output:

<warning>Package "craftcms/vue-asset" listed for update is not installed. Ignoring.</warning>
<warning>Package "yiisoft/yii2-shell" listed for update is not installed. Ignoring.</warning>
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package laravel/homestead could not be found in any version, there may be a typo in the package name.
  Problem 2
    - The requested package laravel/homestead could not be found in any version, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
<warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
{
    "require": {
        "aelvan/mailchimp-subscribe": "3.0.3",
        "craftcms/aws-s3": "1.2.11",
        "craftcms/cms": "3.5.8",
        "craftcms/contact-form": "2.2.7",
        "craftcms/redactor": "2.7.4",
        "vlucas/phpdotenv": "^2.4.0"
    },
    "autoload": {
        "psr-4": {
            "modules\\": "modules/"
        }
    },
    "config": {
        "sort-packages": true,
        "optimize-autoloader": true,
        "platform": {
            "php": "7.4"
        }
    },
    "scripts": {
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ]
    },
    "require-dev": {
        "laravel/homestead": "^7.20"
    }
}
2
  • Please post your composer.json, looks like a misconfiguration.
    – MoritzLost
    Nov 22 '21 at 15:07
  • @MoritzLost Ok adding the file below
    – JohnC
    Nov 22 '21 at 15:50
1

Your composer.json indicates that the laravel/homestead package couldn't be found. This is strange, as the package does exist, even though you're requiring a heavily outdated version. Anyway, you can try requiring a current version of the dependency to see if that fixes it:

composer require --update-with-all-dependencies laravel/homestead:^12.0

Another option would be to remove that dependency altogether, as it doesn't look like you need it anymore and you can still install Homestead on your local development machine.

1
  • This fixed the issue composer remove laravel/homestead for development Instance
    – JohnC
    Dec 9 '21 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.