Got a Feed Me feed set up to scrape a CSV that is being added to the server via FTP daily. The FTP is via a separate user account and the folder the file is being saved to is accessed via a symlink on the server.

The file is set in Feed Me as a relative path: ../resources/file.csv

We set up a CRON job to hit the Feedme endpoint on an hourly basis but it is throwing an error:

Unable to reach ../resources/file.csv. Message: cURL error 6: Could not resolve host each time

However I can access the element map just fine via the CP (showing it can read/access the file) and if I trigger the feed via the CP then it works okay.

Any thoughts on why triggering via a CRON/Direct Feed URL would not work but via the CP is fine?


  • Where is this folder, relative to your project's root (where your craft executable is)?
    – Oli
    Commented Jul 30, 2021 at 10:18
  • @Oli the folder is in the same application folder as the craft executable. However the file it is reading is being written to by another (FTP) user although the both users belong to the same group on the server Commented Jul 30, 2021 at 17:09

1 Answer 1


You can use Yii aliases in the feed URL setting.

In the example below, I used the @storage alias which resolves to /var/www/html/craft/storage on my server, and then added the path to my file, relative to the Craft storage folder. As a result, the feed URL is the absolute path: /var/www/html/craft/storage/import/business-units.csv.

You can use any of the aliases listed on the /admin/utilities/system-report page.

Example: @root/../resources/file.csv, if your CSV is located in the parent directory of your Craft directory.

Screenshot of the settings page of a FeedMe feed

  • Thanks @nstCactus - will try with an alias and see if that works but it really does seem quite random. For example having set to run hourly have had two instances in the last 24 hours where it has worked fine and the remaining 22 have reported being unable to reach the specified file Commented Jul 30, 2021 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.