0

I'm struggling with a downloaded copy of a clients Craft 3 based website.

I've downloaded the entire project, and have tweaked the .env file and .htaccess for my local mac's setup.

The site itself loads in terms of the front end and can establish a database connection. I can however not reach the admin site(have checked both via /admin/ and via ?p=admin/login). I get a 404 error either way.

Other friendly URLs are working but break if I sabotage the .htaccess file... makes me think the .htaccess is fine.

I've looked in general.php and the cpTrigger is set to admin.

No useful errors are being recorded in storage/logs (although these files are updating). The only errors seem to be about deprecated functions.

Any suggestions on what else to look at?

4
  • I'm writing this as a comment and not answer because I'm not 100% sure - are there any URL's hardcoded in the database? You can access /admin fine on the actual production URL, I assume? Jul 5, 2021 at 18:56
  • Is it a Craft-styled 404 or a webserver-styled 404?
    – Brad Bell
    Jul 5, 2021 at 22:48
  • @BradBell for the /admin requests I'm getting a very plain apache style 404 page. For other errors I resolved with the front-end site I was getting the detailed CraftCMS error pages (in development mode).
    – steve
    Jul 6, 2021 at 15:20
  • @good_afternoon Not seeing any hardcoded URLs in the database sadly :(
    – steve
    Jul 6, 2021 at 15:21

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.