I'm stepping through Craft release versions while updating a Craft v3 site that is many versions behind. 3.5.7 works fine, but after using $ composer require craftcms/cms:3.5.8 to update to 3.5.8, loading the CP resolves in an error:

PHP Fatal Error – yii\base\ErrorException
Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes)

I've poked through the various posts that talk about this type of error and have tried a few things without success.

  • updated memory_limit to 512MB (even tried setting memory_limit = -1, still didn't work)
  • updated max_execution_time to 120
  • set enableTemplateCaching to false (@brad-bell suggested setting cacheElementQueries to false in this post, but I think that setting's been deprecated)
  • ran garbage collection
  • confirmed that craft_templatecacheelements, craft_templatecachequeries, and craft_templatecaches are all empty (0 rows)
  • commented out all of the {% cache %} tags in our templates
  • as a last-ditch effort, I moved all of our templates out of the templates directory- made no difference

I'm at a real impasse. The db itself is 395.2MB and contains 244 tables.

Our goal is to get Craft up to date in the hopes that it'll fix a Sprout Forms Pro issue that we're experiencing.


This is fixed. @brad-bell helped me to understand that the problem was likely being caused by custom module code - he was able to import our database, install composer packages, and then update to the latest Craft version. The big difference between his process and ours was that he didn't have our custom module code.

I was able to find the cause by removing all of our modules from autoload and then adding them back one by one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.