0

I had a Craft Site, which I'll refer to here as the old site. I replaced it with a new site on the same server. To do this I overwrote the old site's database and files. I kept the old site's public web root folder intact, and assigned a different web root folder to my new site via my hosting control panel.

Long story short, my new site launched and everything looks great. Except... when Craft loads my 404 template it shows the one from my old site. That template, to the best of my knowledge, doesn't exist on this server anymore (see update below). It's a new database. I have a 404 template for my new site that works fine on my local dev machine, but in production it will only show me the old site's 404.

Anybody know how I can troubleshoot this? I renamed the old site's web root folder (which, again, I'm not even sure is part of the problem) and that didn't change anything. I've cleared my caches. I've tested on multiple devices.

I'm hosted at FortRabbit, if that helps.

UPDATE: I found a copy of the old site's 404 template in a file in the compiled_templates folder. I tried renaming that file with no luck (Craft just generates a new one). But it all certainly feels related. Any ideas?

2
  • Have you tried clearing the template caches? If not, go into the control panel under Utilities > Clear Caches and clear the "Template caches" there.
    – Alex Roper
    Dec 2 '20 at 8:54
  • Yeah, I started there. Also tried the option to 'invalidate template caches' to no avail.
    – Dannie
    Dec 3 '20 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.