I have installed SEOMatic. However, I am getting incorrect canonical URLs. Here is an example: https://jenoffvanhulle.com/en/ The URL has a trailing slash, the canonical URL not

A second problem is that I'm having redirect chains. e.g. www.jenoffvanhulle.com -> https://www.jenoffvanhulle.com -> https://jenoffvanhulle.com

It's clear that some settings are not right. Can somebody help me solving both issues please? Below you find a listing of some relevant settings:

  1. htaccess
# Redirect www traffic to non-www
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
  1. general config
'siteUrl' => [
'nederlands' => 'https://jenoffvanhulle.com/',
'english' => 'https://jenoffvanhulle.com/en/',
  1. base URL settings in Craft

enter image description here

  1. SSL certificate settings

enter image description here

1 Answer 1


Update to the latest SEOmatic; the issue you're describing is a case where SEOmatic operates the same as Craft CMS does in terms of returning a root URL without a trailing slash, but we added a fix to SEOmatic 3.3.18 anyway.

  • Hi Andrew, I have version 3.3.24 installed
    – Jenoff
    Dec 1, 2020 at 13:33
  • My guess would be that something else is amiss, maybe a server-side rewrite? Dec 1, 2020 at 16:01
  • yes probably, but I can't find out exactly what at this moment. I will look further. thanks anyway for your help
    – Jenoff
    Dec 1, 2020 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.