1

Not sure whether I should be posting this here or as a Github issue, but when trying to install NY Studio's Transcoder plugin, I get:

Composer output: Package "craftcms/vue-asset" listed for update is not installed. Ignoring. Package "yiisoft/yii2-shell" listed for update is not installed. Ignoring. Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1

The requested package nystudio107/craft-seomatic (locked at 3.3.17, required as ^3.3.18) is satisfiable by nystudio107/craft-seomatic[3.3.17] but these conflict with your requirements or minimum-stability.

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

composer.json looks like this:

{
  "require": {
    "barrelstrength/sprout-fields": "^3.8.3",
    "craftcms/cms": "^3.4.24",
    "craftcms/redactor": "^2.6.1",
    "dukt/analytics": "^4.0",
    "nystudio107/craft-seomatic": "3.3.18",
    "nystudio107/craft-typogrify": "^1.1",
    "ostark/craft-async-queue": "^1.3.3",
    "putyourlightson/craft-blitz": "^3.6.5",
    "topshelfcraft/wordsmith": "^3.2.0",
    "verbb/cp-nav": "^3.0.13.1",
    "verbb/field-manager": "^2.1.8",
    "vlucas/phpdotenv": "^2.4.0"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/",
      "modules\\exifReturn\\": "modules/"
    }
  },
  "config": {
    "sort-packages": true,
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ]
  },
  "repositories": [
    { "type": "composer", "url": "https://packagist.phpcomposer.com"}
  ]
}

Has anyone else had this problem and how did you resolve it?

2

Try changing it to this:

    "nystudio107/craft-seomatic": "^3.3.0",

3
  • Same except error now says The requested package nystudio107/craft-seomatic (locked at 3.3.17, required as 3.3.0) – Tyssen Nov 6 '20 at 1:52
  • Do I need to delete composer.lock and reinstall? – Tyssen Nov 6 '20 at 1:53
  • That's what I did and was able to install. đź‘Ť – Tyssen Nov 6 '20 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.