0

I'm running Craft 2 with PHP 5.6.40 on a Windows 2019 Server under IIS (x64, non-thread-safe, FastCGI). PHP -m doesn't show any issues with my extensions, regardless if I use GD2 or ImageMagick. But if I have either extension enabled, then I get this processing / loading spinner where the images should be rendered if Craft was applying my Transformations:

Processing Spinner

I realized my php.ini had the defaults for max_execution_time = 30 and memory_limit = 128M. I bumped them up to Craft's minimum recommendations of: max_execution_time = 120 and memory_limit = 256M. When that didn't work, I even tried max_execution_time = 0 and memory_limit = 1G. Still no luck, regardless if I used GD2 or ImageMagick.

If I disable both extensions, the processing spinner goes away and my images load untransformed. They are really big images, about 7 MB file sizes that are about 8,000 pixels width by 4,000 pixels height.

I also noticed that if I have GD2 or ImageMagick enabled, and the spinner is loading, the request transformation Task hangs (infinitely?) in the database's "craft_tasks" table.

Is there some other setting I could be missing in my php.ini configuration file?

UPDATE: I receive the following error in my Craft logs (no errors in my web server though), regardless if I have GD2 / ImageMagick enabled or not. So not sure if it's relevant? (It's the only error in the logs.)

2020/10/30 12:53:58 [error] [exception.Craft\HttpException.404] exception 'Craft\HttpException' in D:\Websites\MyWebsite.us\craft\app\controllers\TemplatesController.php:72
Stack trace:
#0 [internal function]: Craft\TemplatesController->actionRender('FPURL.xml', Array)
#1 D:\Websites\MyWebsite.us\craft\app\framework\web\actions\CAction.php(109): ReflectionMethod->invokeArgs(Object(Craft\TemplatesController), Array)
#2 D:\Websites\MyWebsite.us\craft\app\framework\web\actions\CInlineAction.php(47): CAction->runWithParamsInternal(Object(Craft\TemplatesController), Object(ReflectionMethod), Array)
#3 D:\Websites\MyWebsite.us\craft\app\framework\web\CController.php(308): CInlineAction->runWithParams(Array)
#4 D:\Websites\MyWebsite.us\craft\app\framework\web\CController.php(286): CController->runAction(Object(CInlineAction))
#5 D:\Websites\MyWebsite.us\craft\app\framework\web\CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#6 D:\Websites\MyWebsite.us\craft\app\framework\web\CWebApplication.php(282): CController->run('render')
#7 D:\Websites\MyWebsite.us\craft\app\framework\web\CWebApplication.php(141): CWebApplication->runController('templates/rende...')
#8 D:\Websites\MyWebsite.us\craft\app\etc\web\WebApp.php(290): CWebApplication->processRequest()
#9 D:\Websites\MyWebsite.us\craft\app\framework\base\CApplication.php(185): Craft\WebApp->processRequest()
#10 D:\Websites\MyWebsite.us\craft\app\index.php(62): CApplication->run()
#11 D:\Websites\MyWebsite.us\public_html\index.php(46): require_once('D:\\Websites\\MyW...')
#12 {main}
REQUEST_URI=/FPURL.xml
2
  • 1
    Regardless of which one you're using, I'd start by trying to figure out why they're failing. That'll either be in Craft's logs (craft/storage/runtime on Craft 2) or your web server's error logs.
    – Brad Bell
    Oct 30, 2020 at 3:07
  • @BradBell So my web server's log doesn't show anything, but the Craft logs you mentioned does show an error (regardless if I have GD2 / ImageMagick enabled or not). I was initially ignoring it thinking it wasn't relevant but I just updated my question post with the error. Does it sound like it could be related?
    – J.D.
    Oct 30, 2020 at 12:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy