I've migrated a website with CraftCms 2 from local to a pre-production server. Everything is working fine but, I don't know why, I only can go to the admin panel with locale code before /admin. I mean, if I write domain.com/admin, it doesn't work. But if I write domain.com/es/admin it works. And this don't happen in local server, only in pre-production.

I get message "Not Found. The requested URL /admin was not found on this server." Instead of a 404 from my webpage.

It works fine in others projects under craft with the same structure and, as I said, in local server works fine too. In root I have:

  • assets/
  • craft/
  • en/
  • va/
  • es/
  • index.php

Any idea? Thanks.

1 Answer 1


Solved, I left an .htaccess file in root. It wasn't in local server neither, but It seems it was some config in virtual host or something like that to solve it. Once I find this .htaccess in other craft project, was solved ;)

Don't forget your .htaccess in root!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.