0

I have set up several globals to store the URLs of a company’s social media accounts. Each one is a plain text field, and each one is limited to 254 characters.

This works fine with three of them, but when I came to limit the length of the link for twitter I get this error:

SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
The SQL being executed was: ALTER TABLE `content` CHANGE `field_twitterLink` `field_twitterLink` varchar(1016)

I have tried this several times, and I am definitely not hitting a key accidentally, the amount I’m entering is 254, the field is plain text. This matches the other fields that worked correctly.

If I omit the length, it works. And it works on the other links.

It’s not a catastrophe, but I would like to understand what’s going wrong. Any insights appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.