1

Every time I try to run an update, I get these errors. Installing plugins won't work either. I'm using Media Temple / Grid server hosting. I've increased the file size limits in php.ini as well. But I'm at a loss.

Status: Internal Server Error

Response:

PHP Fatal Error 'yii\base\ErrorException' with message 'Out of memory (allocated 226500608) (tried to allocate 4096 bytes)'
in /nfs/c07/h01/mnt/179491/domains/bluepearl.villas/vendor/composer/composer/src/Composer/DependencyResolver/RuleWatchGraph.php:52
Stack trace:
#0 [internal function]: yii\base\ErrorHandler->handleFatalError()
#1 {main}

3
  • If you go to Utilities->PHP Info in the control panel and search for memory_limit what is it set to? And is that the same value you changed the php.ini memory_limit setting to be?
    – Brad Bell
    Aug 31 '20 at 0:33
  • Its set to 99M, and the php.ini reflects that as well.
    – Noah Yamen
    Aug 31 '20 at 16:32
  • I just bumped it to 512M, still the same error.
    – Noah Yamen
    Aug 31 '20 at 17:14
0

It looks like Media Temple Grid accounts are limited to 99MB of memory for PHP: https://mediatemple.net/community/products/grid/204643740/cgi-and-php-resource-limits

My guess is that they are ignoring whatever values are set in php.ini for memory_limit, but you can contact them to verify.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.