1

we wanted to remove blog categories pages, author pages, blog tag pages from appearing in Google Search results as they were taking unnecessary real estate. To do that, we used 'noindex' option available in Sprout SEO - > Sections -> Category (Blog) -> Robots -> noindex. (Screenshot 1)

enter image description here

We were able to achieve that and now our these categories pages don't appear on Google. That's good. But on checking our Search Console, Google gives us a warning that we have no-indexed pages in our sitemap. The exact error is "Submitted URL marked ‘noindex’". (Screenshot 2).

enter image description here

Any idea why this might be happening? One of the things I tried is to disable the Section itself which in-result disabled the category sitemap and removed the no-index tag from all the category pages. I think the solution might be if we could noindex pages without creating a sitemap. We have been trying to solve this issue and any help would be beneficial. (I also posted this issue on the plugin's Github and didn't get a reply for about 2 weeks so re-posted it here in a hope to get some insight).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.