1

I recently renewed many licenses on a previously-neglected site and have been attempting to update both the CMS and the plugins. Despite having a Freeform Pro license, the plugin appears as Freeform Lite on the update list, and attempting to update it from 2.3.0 to 2.5.27 results in the error message:

Error: Client error: POST https://api.craftcms.com/v1/composer-whitelist resulted in a 400 Bad Request response: {"message":"Unknown package/constraint: solspace/craft3-freeform@2.5.27"}

The CMS is currently at 3.0.41.1, and attempting to update to 3.4.22.1 results in an error also referencing Freeform:

Composer output: Package "craftcms/vue-asset" listed for update is not installed. Ignoring.
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package solspace/craft3-freeform 2.5.27 exists as solspace/craft3-freeform[3.0.0-beta.1, 2.5.24, 2.5.23, 2.5.22, 2.5.21, 2.5.20, 2.5.19, 2.5.18, 2.5.17, 2.5.16, 2.5.15, 2.5.14, 2.5.13, 2.5.12, 2.5.11, 2.5.10, 2.5.9, 2.5.8, 2.5.7, 2.5.6, 2.5.5, 2.5.4, 2.5.3, 2.5.2, 2.5.1, 2.5.0, 2.4.3, 2.4.2, 2.4.1, 2.4.0, 2.3.4, 2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.2, 2.2.1, 2.2.0, 2.1.1, 2.1.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 2.0.0-beta.20, 2.0.0-beta.19, 2.0.0-beta.18, 2.0.0-beta.17, 2.0.0-beta.1, 2.0.0-beta.2, 2.0.0-beta.3, 2.0.0-beta.4, 2.0.0-beta.5, 2.0.0-beta.6, 2.0.0-beta.7, 2.0.0-beta.8, 2.0.0-beta.9, 2.0.0-beta.10, 2.0.0-beta.11, 2.0.0-beta.12, 2.0.0-beta.13, 2.0.0-beta.14, 2.0.0-beta.15, 2.0.0-beta.16] but these are rejected by your constraint.
Problem 2
- The requested package solspace/craft3-freeform (locked at 2.3.0, required as 2.5.27) is satisfiable by solspace/craft3-freeform[2.3.0] but these conflict with your requirements or minimum-stability.

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Based on other posts here, I've attempted to remove the "3" from "craft3-freeform" in the composer.json file (since reverted) and have attempted to run "composer update", though it appears I do not have shell access here. I know these are some outdated versions here, but any recommendations?

Thanks for your time and insight.

1

Figured it out, posting here in case someone runs into something similar. I opened up the composer.json file in the root and removed the line "solspace/craft-freeform": "2.5.27" from the "required" list.

From there, I was able to update Craft, and then I was able to update Freeform. All is well, and all up-to-date!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.