1

I’ve set up a multilingual craft site. My primary site is BE and base Url is set to / The two other ones are NL which base Url is set to /nl and LU which is set to /lu All the three website have en-US as a language. When I google my website and I say I speak Dutch, the only website that is showing is the NL version. It’s not even showing the BE or LU version.

Any way I can change this?

Thanks in advance!

1
  • This is nothing to do with Craft - you can add whatever front end code you need. In your case, have you set the appropriate hreflang meta tags and the lang attribute of the root html tag to give Google some hints as to the appropriate locale? I'm no expert here but I think you may also be able to specify a preferred locale in Google Webmaster Tools. Jun 5, 2020 at 16:50

1 Answer 1

1

Apparently SEOMatic provides an automatic hreflang to your source. So changing the language in the settings tab helped for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.