1

After upgraded our Craft from 3.3 to 3.4.14 we have noticed that there is a new Javascript on the footer of the homepage (frontend) that runs "index.php?p=actions/queue/run".

We run the tasks via crontab and there is no need for that.

How can we disable it on the frontend?

Thank you

1 Answer 1

2

If you set runQueueAutomatically to false in your config/general.php file, that will disable that behavior.

2
  • 1
    Brad, how is this done in a plugin that returns data? (without setting the runQueueAutomatically to false in the global Craft instance) . I had a custom module pre-3.4 that now returns the queue runner script after its return data.
    – jpea
    Jun 2, 2020 at 14:40
  • The documentation states that it would only inject this in control panel requests, but I see these calls injected into my frontend sites (which, I would like to disable).
    – jishi
    Sep 30, 2020 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.