1

I'm getting the following error when I'm trying to update a matrix:

"Field Limit is too big for your chosen Column Type.""

I'm trying to add a new block type but this error keeps getting up on fields that already exist in other block types. The problem seems to related to the plain text field type. I've read somewhere about the field limit exceeding the mysql varchar length but 80 or 100 shouldn't be a problem, no?

Does anyone have an idea what might be the problem?

I'm running on:

  • PHP version 7.2.15
  • OS version Linux 4.19.76-linuxkit
  • Database driver & version MySQL 5.7.26
  • Image driver & version Imagick 3.4.3 (ImageMagick 6.9.7-4)
  • Craft edition & version Craft Pro 3.4.19
  • Yii version 2.0.35
  • Twig version 2.12.5
  • Guzzle version 6.5.3
  • Imagine version 1.2.3-dev

enter image description here

0

If you scroll down a little bit from your screenshot, you'll see an "advanced" toggle for the Plain Text field settings.

In there is a "Column Type", which I'm guessing is set to varchar(255B) for you.

Set that to Text and that should solve it for you.

enter image description here

| improve this answer | |
  • Thanks! This fixed the issue but I'm a bit confused as why this suddenly is a problem. – valley May 27 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.