1

I am having issues with search engines picking up my Craft site. I'm seeing x-robots-tag: none when reviewing my site's headers - which is shorthand for "no-index and no-follow".

  • The following is commented out in my nginx file as advised: location = /robots.txt { access_log off; log_not_found off; }
  • I have restarted nginx and the problem persists.
  • Robots.txt exists and works - I am using the SEOmatic plugin which generates the robots.txt file.
  • I have checked I'm using the live environment - which enables indexing.

How do I fix indexing at the header level?

2

Solved

There is an environment override in SEOmatic's settings. This was set to local instead of live.

| improve this answer | |
  • Just to add to this... on the SEOmatic Dashboard, it will show you the Environment that SEOmatic is currently using... and clicking on the (i) icon will show you details of why. nystudio107.com/docs/seomatic/… – andrew.welch May 4 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.