1

I have a very strange situation.

A production site is running Craft3.0 - there is no easy way to get this site up to Craft3.4. This is not possible at present because of the server and upgrading PHP.

I have used FeedMe locally on Craft3.4 to import a few thousand entries into the site.

Now I have these entries on my local machine running Craft3.4, and I need them placing onto the live site which is Craft3.

Exporting that tables that I think are needed results in multiple copies of the entries being created. E.g. 5 of the same news articles all with the same slug.

I am exporting and then importing the following tables...

  • craft_assets (because of images on the entries)
  • craft_categories
  • craft_content
  • craft_elements
  • craft_elements_sites
  • craft_entries
  • craft_relations
  • craft_userpermissions
  • craft_userpermissions_usergroups
  • craft_userpermissions_users
  • craft_userpermissions_users
  • craft_users (because of authors)

Am I missing a table?

Am I confusing Craft3 by adding a certain table?

Is this impossible because of the differences between Craft3 and 3.4? I have looked at the tables and they are identical so I am unsure why it is getting itself into such a state.

I realise this is a very odd and suboptimal situation - but I am stuck with this at present with no way to upgrade the server and the PHP version.

1

I would highly advise against trying to import anything directly into tables. I don't know when it was added, but everything now has a global identifier (UID) which you cannot add manually. FeedMe sounded like the right approach; I'd look at running that import on the production site and letting FeedMe import the content for you through the control panel rather than trying to directly add it to the database.

| improve this answer | |
  • Thanks for the heads up on the UID. I cannot get FeedMe running on the production server because it requires PHP 7.3 and getting to that is going to require a huge amount of time. – Jake N Apr 28 at 11:05
  • @JakeN FeedMe should work fine with PHP 7.0. Why do you say it requires PHP 7.3? – Brad Bell Apr 29 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.