1

I hadn't updated site in a while now. Checked Craft's control panel and something like 12 updates were available and i clicked update. "Updating Composer dependencies (this may take a minute)…" has been on display for over half an hour, maybe an hour, and the activity spinner just keeps spinning. No error report or any feedback. I'm reluctant to stop the process as the site is currently unavailable due to this situation.

1

If you have ssh access to your remote server you might be better off just updating composer via command line. I find it's ofter faster and less prone to causing errors by updating composer and craft this way.

Let me know if you need help doing that.

| improve this answer | |
  • Thank you. I backed out of/aborted the update attempt and no harm was done to the site, backend or public facing. I have to do a few other unrelated things first but will get back to updating the site later. Thank you very much for your offer of help. Very generous! – Richard Apr 17 at 17:08
  • Whoa! At first I thought no updates had happened (because I had both the remote and local sites open and was looking at the local) but the remote site, which was the problematic spinning update site, and the site I aborted the update for, was indeed updated. So...for now, that's great. Nevertheless, thanks again for your advice. – Richard Apr 17 at 17:17
  • No problem. Here's some craft reference docs showing you how to update craft and plugins via CLI: docs.craftcms.com/v3/… – Johnronomous Bosch Apr 17 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.