1

We have a website built in Craft 3.4.14 and we are moving it to a hosting company with CentOS 7, using Plesk Obsidian 18.0.5.

The hosting company has told us that they have upgraded Composer from version 1 to version 2. On my local machine I have been using version 1.10. However, I try to run Composer on the server and I get these issues: -

  • craftcms/plugin-installer 1.5.3 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
  • craftcms/plugin-installer 1.5.4 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match your constraint.
  • craftcms/cms 3.4.14 requires craftcms/plugin-installer ~1.5.3 -> satisfiable by craftcms/plugin-installer[1.5.4, 1.5.3].
  • Root composer.json requires craftcms/cms 3.4.14 -> satisfiable by craftcms/cms[3.4.14].

Is there a way around these issues so that we can get Craft CMS installed please?

Thank you for your time.

1

Composer 2 support has been drafted over at craftcms/plugin-installer#4. We’ll merge that in once Composer 2 is officially released.

~~In the meantime, if you really need to get Craft working with Composer 2, follow the instructions at craftcms/plugin-installer#3.~~

UPDATE: craftcms/plugin-installer and yiisoft/yii2-composer have both been updated to support Composer 2.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.