0

I had an image transform set on an entry that was working as expected. I updated the code, and it didn't work, so I reverted back to the old transform. It was literally going from

src="{{ image.getUrl('featuredImage') }}"

to

src="{{ image.getUrl('cardImage') }}"

The image didn't load, so I reverted back to featuredImage, and it still isn't working. I checked my server logs and there wasn't anything noticeable. In my dev console the request URL is Request URL:https://example.com/index.php?p=actions/assets/generate-transform&transformId=1 and Status Code: 500 Internal Server Error

Any thoughts?

Thanks in advance!

5
  • Check Craft's logs at storage/logs
    – Brad Bell
    Commented Feb 25, 2020 at 1:09
  • Is devMode on? If it is, you should see more than just the server error code.
    – Paul
    Commented Feb 25, 2020 at 8:23
  • Is your transform setup in the admin area or a template transform? If it's in the template code, is it inside of a cache tag?
    – jpea
    Commented Feb 25, 2020 at 19:00
  • @BradBell Thanks for the reminder. I think I know the root of the problem, but not sure how to solve it: Some weeks ago, my user (User1) became "corrupted" somehow. My hosting provider's solution was create a new user (User2) and move everything over there. Mostly everything seems to be sorted, but I'm seeing errors in web.log as follows:League\Flysystem\Exception] League\Flysystem\Exception: Impossible to create the root directory "/home/User1/example.com/img/travels". mkdir(): Permission denied in /home/User2/craft/vendor/league/flysystem/src/Adapter/Local.php. Any idea?
    – Shad
    Commented Feb 25, 2020 at 23:32
  • Huh... yeah some sort of permissions issue. I think I'd push back on the host to investigate since they seem to be the cause of it. :)
    – Brad Bell
    Commented Feb 26, 2020 at 0:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.