1

I have a Craft CMS installed in a development environment thewebsite.test.

I can't get it to trial paid plugins and Craft Pro.

It appears Craft doesn't recognise it's in a development environment?

Application Info

  • PHP version 7.4.2
  • OS version Linux 4.15.0-74-ubuntu
  • Database driver & version MySQL 5.5.5
  • Craft edition & version Craft Pro 3.4.6.1

I'm running Windows 10 with Vagrant/Homestead with Craft installed on a Virtual Machine in VirtualBox.

The same setup on a Mac does not have any issues with licensing.

I have copied the database and updated the .env file from the Mac install, and everything appears to be working except for the licensing issues.

Is there any way to force Craft CMS to recognise a dev environment?

  • Are you able to load the "updates" page in the Craft control panel without any errors or issues? – Brad Bell Feb 21 at 4:41
  • Yes, can load the "updates" page in the control panel. No errors. Two updates available 3.4.7 and 3.4.7.1 – Nick Feb 21 at 5:29
  • Well, now I'm confused. Can you shoot your config/license.key file over to support@craftcms.com and reference this SE post? – Brad Bell Feb 21 at 20:22
  • I never solved this. I instead switched to running Craft in DDEV instead and didn't have the issue. I suspect it may have been something in the vagrant stack combined with using GitBash WSL and the Untuntu VM. Somethings may have been run or installed in the wrong terminal/environment? – Nick Apr 20 at 9:41
1

did you copy the license.key from your Mac environment to the Windows/Vagrant environment? Maybe deleting the license.key would help in this case.

| improve this answer | |
  • Hi Denis, Yes copied the license.key and tried deleting license.key and Craft still doesn't appear to recognise it's in a development environment. Also deleted /vendor and /storage/* folders and did a composer install and still no luck. – Nick Feb 21 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.