1

I'm unfortunately dealing with a very old system that hasn't been updated in a long time. I've been able to update it up to 3.0.41.1 but once I attempt to go any further I get tons of different errors. They primarily seem to be migrations. I keep having to do a restore of the DB I'm working with over and over to try to sort this out but I'm not sure what else to be looking for.

Any recommendations? (besides updating things at the right time?)

UPDATE 1:

When attempting to update from the web interface (which i think attempts to go straight to 3.4.5) I consistently get the following error:

Composer output: Package "craftcms/vue-asset" listed for update is not installed. Ignoring.
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for craftcms/cms 3.4.5 -> satisfiable by craftcms/cms[3.4.5].
- craftcms/cms 3.4.5 requires twig/twig ~2.12.0 -> satisfiable by twig/twig[v2.12.3, v2.12.2, v2.12.1, v2.12.0] but these conflict with your requirements or minimum-stability.
Problem 2
- spicyweb/craft-embedded-assets 2.0.12 requires craftcms/cms ^3.0.0 -> satisfiable by craftcms/cms[3.4.5].
- spicyweb/craft-embedded-assets 2.0.12 requires craftcms/cms ^3.0.0 -> satisfiable by craftcms/cms[3.4.5].
- spicyweb/craft-embedded-assets 2.0.12 requires craftcms/cms ^3.0.0 -> satisfiable by craftcms/cms[3.4.5].
- craftcms/cms 3.4.5 requires twig/twig ~2.12.0 -> satisfiable by twig/twig[v2.12.3, v2.12.2, v2.12.1, v2.12.0] but these conflict with your requirements or minimum-stability.
- Installation request for spicyweb/craft-embedded-assets 2.0.12 -> satisfiable by spicyweb/craft-embedded-assets[2.0.12].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
  • 1
    Can you post your current composer.json file contents? – Brandon Kelly Feb 8 '20 at 13:35
1

There used to be a bug in Craft 3.0 (fixed in 3.0.19) where, if an error occurred during an update, your composer.json file could be left in a weird state where it was directly requiring all of Craft’s dependencies (recursively). My guess is that this happened to you.

Try opening your composer.json file and see if your require setting contains a whole bunch of dependencies, such as twig/twig.

If so, then just delete all of the dependencies that don’t need to be in there. If the file is tracked in Git, then you should be able to look up its history and find the point where all of the extra dependencies were added. Otherwise you’ll need to figure that out for yourself.

  • You definitely need craftcms/cms.
  • You probably need vlucas/phpdotenv, if any of your environments are using a .env file.
  • If you have any plugins installed, then each of them will have one corresponding dependency.
  • Beyond that, everything else should be safe to remove (unless you intentionally added something else).

Once you’ve removed everything you don’t need, try changing your craftcms/cms requirement to ^3.4.5 and then run composer update. As a sanity check, pay attention to which dependencies get removed in the process, in case you accidentally over-corrected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.