I successfully installed Craft locally and my primary site is up and running, but when I add a new site with it's own base URL I cannot access it due to a HTTP 503 error.

I've tried various combinations of environment variables and aliases for the URL, and for now I just added the base URL directly in the CP (anotherdomain.locahost).

I also played around with various vhosts settings in XAMPP (Win 10) to no avail. It seems to me that the vhost is properly configured.

Here is my stack trace, any help would be much appreciated.

2020-01-21 15:07:49 [-][-][-][trace][yii\web\Application::handleRequest] Route requested: 'templates/render'
2020-01-21 15:07:49 [-][-][-][trace][yii\base\Controller::runAction] Route to run: templates/render
2020-01-21 15:07:49 [-][-][-][error][yii\web\HttpException:503] craft\web\ServiceUnavailableHttpException in D:\Web\dev\folder\vendor\craftcms\cms\src\web\Controller.php:163
Stack trace:
#0 D:\Web\dev\folder\vendor\craftcms\cms\src\controllers\TemplatesController.php(72): craft\web\Controller->beforeAction(Object(yii\base\InlineAction))
#1 D:\Web\dev\folder\vendor\yiisoft\yii2\base\Controller.php(155): craft\controllers\TemplatesController->beforeAction(Object(yii\base\InlineAction))
#2 D:\Web\dev\folder\vendor\craftcms\cms\src\web\Controller.php(187): yii\base\Controller->runAction('render', Array)
#3 D:\Web\dev\folder\vendor\yiisoft\yii2\base\Module.php(528): craft\web\Controller->runAction('render', Array)
#4 D:\Web\dev\folder\vendor\craftcms\cms\src\web\Application.php(299): yii\base\Module->runAction('templates/rende...', Array)
#5 D:\Web\dev\folder\vendor\yiisoft\yii2\web\Application.php(103): craft\web\Application->runAction('templates/rende...', Array)
#6 D:\Web\dev\folder\vendor\craftcms\cms\src\web\Application.php(284): yii\web\Application->handleRequest(Object(craft\web\Request))
#7 D:\Web\dev\folder\vendor\yiisoft\yii2\base\Application.php(386): craft\web\Application->handleRequest(Object(craft\web\Request))
#8 D:\Web\dev\folder\web\index.php(21): yii\base\Application->run()
#9 {main}
  • 1
    Do you get the same result in an incognito window or a different browser?
    – Oli
    Jan 21, 2020 at 14:19
  • Yes, and in the live preview in the CP as well. I've managed to get it to work on another project, but on another machine.
    – Paul
    Jan 22, 2020 at 2:38

1 Answer 1


System status was disabled, enabling it solved the problem.

Now I'm not sure if this is the expected behavior, what threw me off was that I could still preview the primary site. I'm guessing on multi-site installs it's best to disable at the site level rather than the system level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.