1

I'm testing my email and I'm seeing the following error in the web logs:

"Error sending email: Process could not be started [The system cannot find the path specified. craft cms"

Does anyone know what that means?

In my local environment I am not seeing what exactly causes this error. I've tried following this article on Craft but it seems like this is not relevant to the error I am receiving?

https://craftcms.com/guides/troubleshooting-email-errors

Also, I don't see the file structure they mention on this article, I found the error log on storage/logs/web.txt.

I've tried also changing my email to SMTP with Outlook credentials to no avail.

The images show the directory structure I'm seeing: https://i.stack.imgur.com/yvDex.png

0

Error sending email: Process could not be started

That error means that you've got sendmail selected as the mail driver for Craft under Settings->Email in the Control Panel, but the sendmail executable is either not installed or configured properly on your server.

Also, I don't see the file structure they mention on this article, I found the error log on storage/logs/web.txt.

That's correct... the article was written for Craft 2 and you're using Craft 3. The log paths changed a bit between the two versions.

I've tried also changing my email to SMTP with Outlook credentials to no avail.

I'm guessing you got a different error then? I'd suggest setting up Craft with a transactional email provider like https://postmarkapp.com/ or https://sendgrid.com/.

There are Craft plugins for each (https://plugins.craftcms.com/sendgrid and https://plugins.craftcms.com/postmark), they'll be more reliable than sendmail and easier to setup than SMTP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.