1

Description

I have a JSON feed which contains an external URL like "https://example.com" (entries/external_link/url). There is no error in feed-me logs when I run it, all the text data and assets are imported without any problems. Except for my URL field. I get "[ ]" instead of "https://example.com".

Any help on this ?

JSON exemple

{
    "entries": [
        {
            "id": "140",
            "type": "regular",
            "title": "Banner import title (fr)",
            "subtitle": "Banner import subtitle (fr)",
            "body": "<p>Banner import body&nbsp;(fr)</p>",
            "internal_link": [{
                "type": "node",
                "title": "test",
                "id": "6",
                "cta": "Banner import link text (fr)"
            }],
            "external_link": {
                "cta": "Banner import link text (fr)",
                "url": "https://example.com"
            },
            "images": [{
                "url": "",
                "caption": ""
            }],
            "placements": [],
            "postdate": "2019/12/10",
            "status": "1"
        },
    ],
    "nextPage": "",
    "length": 20,
    "totallength": 23
}

Additional info

  • Plugin version: 4.1.2
  • Craft version: 3.3.17
| improve this question | | | | |
2

Have you tried to make external_link an array?

"external_link": [{
    "cta": "Banner import link text (fr)",
    "url": "https://example.com"
}],
| improve this answer | | | | |
  • Yes I did try that but I've got the same result... Anyway thanks for your answer. – Elodie Grondin Dec 11 '19 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.