1

I keep seeing a Craft 3 site with queue sticking and clearing the cache doesn't clear it.

I have been thru plugins fixed some errors and now it all comes down to same issues:

PHP Fatal error: Uncaught PDOException: SQLSTATE[HY000]

The specifics are:

    thrown in /home/mydomain/vendor/yiisoft/yii2/web/Response.php on line 366
[30-Oct-2019 19:21:47 UTC] PHP Fatal error:  Allowed memory size of 1610612736 bytes exhausted (tried to allocate 413696 bytes) in /home/mydomain/vendor/  
yiisoft/yii2/db/Command.php on line 1290
[30-Oct-2019 19:21:47 UTC] PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered   queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute. in /home/mydomain/vendor/yiisoft/yii2/db/Command.php:1290
Stack trace:
#0 /home/mydomain/vendor/yiisoft/yii2/db/Command.php(1290): PDOStatement->execute()
#1 /home/mydomain/vendor/yiisoft/yii2/db/Command.php(1158): yii\db\Command->internalExecute('SELECT *\nFROM `...')
#2 /home/mydomain/vendor/yiisoft/yii2/db/Command.php(399): yii\db\Command->queryInternal('fetchAll', NULL)
#3 /home/mydomain/vendor/yiisoft/yii2/db/Query.php(237): yii\db\Command->queryAll()
#4 /home/mydomain/vendor/yiisoft/yii2/db/ActiveQuery.php(133): yii\db\Query->all(NULL)
#5 /home/mydomain/vendor/craftcms/cms/src/services/Categories.php(125): yii\db\ActiveQuery->all()
#6 /home/mydomain/vendor/craftcms/cms/src/service in /home/mydomain/vendor/craftcms/cms/src/templates/_layouts/base.html on line 37

I am not sure how to resolve this. Any ideas?

  • What job is it trying to complete when that happens? – Brad Bell Oct 31 at 19:32
  • It's always clearing template caches... – joomkit Nov 1 at 14:00
  • Is this still an issue? Does it happen on a different environment? – user3788089 Nov 11 at 11:09
  • It happens in production only (staging is on same server) - seems something to do with content requests and template creation but cant find any more useful errors – joomkit Nov 12 at 16:07
  • That's interesting, do you have cache enabled on production and disabled on staging? I've had mysterious errors with cache that were solved by increasing max_allowed_packet in my.conf. If not what else is enabled on production and not on staging? – user3788089 Nov 13 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.