0

Craft 3.3.8

Locally everything is working as expected.

However when I set up the staging site config values are not being respected.

I have allowAdminChanges set to true for staging, however when logged into staging I have no access to settings anywhere.

Additionally on the front end my assets are rending with aliases in the url

<img class="d-block w-100" src="@baseUrl/uploads/slider/_1400x700_crop_0.50.5_75_none/homepage_main1.jpg" alt="slide 1">

Where @baseUrl is set in general.php and used in the assets volume settings like this:

enter image description here

my .env file has ENVIRONMENT="staging" and the relevant bits of general.php are below showing both dev and staging where dev works correctly on my local computer:

    // Dev environment settings
    'dev' => [
        // Dev Mode (see https://craftcms.com/guides/what-dev-mode-does)
        'devMode' => true,
        'allowAdminChanges' => true,
        'aliases' => array(
          'environment' => 'dev',
          'basePath' => 'D:\sites\memoirs',
          'baseUrl'  => 'http://memoirs.test',
          ),
    ],

    // Staging environment settings
    'staging' => [
        // Dev Mode (see https://craftcms.com/guides/what-dev-mode-does)
        'devMode' => true,
        'allowAdminChanges' => true,
        'aliases' => array(
          'environment' => 'staging',
          'basePath' => '/srv/users/memoirs/apps/memoirs',
          'baseUrl'  => 'http://memoirs.domain.com',
          ),
    ],

Please advise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.