2

Craft 3.3.8

Commerce 2 Lite Version

If I change the base currency from default(USD) to NZD or AU in the setting

CP > Commerce > Store Settings > Payment Currencies

and browse to /shop/ or /shop/[otherpages] the website shows error:

Invalid Configuration – yii\base\InvalidConfigException
Payment currency not allowed.
1. in vendor/craftcms/commerce/src/elements/Order.php at line 1580

And if I switch it back to USD it works fine. It also works fine if I am a public register.

I need to use NZD only, if not, I'm open to other work arounds using USD.

  • I am having this issue too - and I cannot find any documentation about it. I think a bug? Or did you get to the bottom of it? – iamkeir Oct 24 at 15:56
  • @iamkeir , No I haven't found a solution yet. Seems like bug, feel free to post an issue on github.com/craftcms/commerce for us. – Jessica Talzor Oct 28 at 21:15
  • I'm in communication with Craft - they recommended I "clear all carts" before changing the currency... but my carts are clear, so I am asking for clarification. I will post if/when I get resolution. May post to GH as well. – iamkeir Oct 30 at 9:57
2

Solution from Craft:

In your Control Panel, click on Commerce then on the vertical subnav (where you have All Orders, New, Shipped....) you will have Active and Inactive carts, this is what Luke suggested you clear.

Essentially, it looks like existing carts may exist which are still using the old currency. Therefore these must be cleared before changing default currency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.