1

Have not accessed my local .test sites in a bit. I tried today. I am getting a series of errors.

At first I could not access any page to include the admin page. I ran Composer update from the command line (within a site's directory) and then updated Craft from the command line (.\ craft update all). I can now access the admin page and successfully login, but I am still getting errors trying to access the actual site's home page (or any page other than the admin page).

HTTP 404 – Not Found – yii\web\NotFoundHttpException Template not found: login

All my templates are located here...(according to Finder) /Users/myname/Documents/Websites/mysite/templates/index.twig

Where should I start?

1

I am presuming Craft 3 because of composer, but you didn't say.

To start with look in your craft templates folder. I would suggest that you simply don't have the template that Craft is looking for.

If you visit the root of your site this is normally templates/index.twig make sure this is present and has no further includes in it (just until you get it working)

Also try looking in storage/logs/web.log for errors.

  • Yep. Craft 3. macOS Catalina. All my templates and my index.twig files are where they were. – Hellyar Sep 26 '19 at 12:51
  • @Hellyar did you run migrations ? Not that I think that would cause those errors. What happens on your index page (site root)? What do the logs say ? – 32423hjh32423 Sep 26 '19 at 13:31
  • No, I did not run migrations. Error on index page is can't find layout – Hellyar Sep 29 '19 at 21:27
  • Twig Template Loading Error – craft\web\twig\TemplateLoaderException Unable to find the template “_layout” in "index" at line 1. But it is where it should be – Hellyar Sep 29 '19 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.